25th May 2018

Shared Mail services E-mail services currently unavailable

Update 15:26 services are now performing as normal.

::::::::::::::::::::::::::::::::::::::::::::::::::::::

Update 15:17 we expect that it will be resolved within 10 minutes.

::::::::::::::::::::::::::::::::::::::::::::::::::::::

We are currently experiencing some issues with our shared e-mail services. We are working to resolv it and hope it will be resolved soon. Please follow this post to keep you updated. We apologize for any inconveniences.